RCS messaging not working

RCS is not working for me with safcom and latest Google messages beta

looks like it is a slow rollout i have tried both beta and stable non seems to work

Just updated my app to latest version and a pop up emerged for the RCS

I set up mine manually.

How? I got the latest na bado

I followed this guide

this is what it shows for me

Which app did you Update…

Haven’t gotten anything yet :confused:

Use Google messages

RCS messages is working on my mum’s phone now but not on mine.

Worked on mine but I got no one to send messages to who has this feature :joy::slight_smile:

1 Like

Is it a dual SIM phone ?

Sorry mate :rofl::rofl::rofl::rofl::rofl::rofl:

those of you who have theirs working which android version are you on?

Android 10 Miui12
latest beta version of the messages app

Tried this on Telkom and it worked (Android 10 One UI 2.1). Hot swapped my Safaricom line and it worked too. But tried it on both my bro’s and cuzo’s phones which are on Safaricom and it didn’t work on their devices. I’m not sure if it’s a network thing ama ni devices

Probably a slow roll out. Like the way it was for VoLTE

1 Like

any android 9 and below user that has theirs working?

Android 9 user here…dual sim too but I enabled it on Safaricom(well, it picked sim 1 automatically so had no choice there).

1 Like

Yaa it is