Error Accessing Wordpress Control Panel Using Faiba 4G

Hello guys,

I’m having trouble accessing my Wordpress CP using Faiba 4G. It takes me to some error webpage saying that my domain’s URL might be broken or something. But when I try to access my WP CP using any other ISP it works.

I have cleared cache, cleared DNS cache and restarted DNS service. Still Faiba 4G won’t allow me to access my WP CP.

What could be the problem here?

1 Like

Welcome to our kind of problems. The number of times I’ve raised this with JTL. We’ve accessed Techweez many times via VPN for this reason. Site becomes inaccessible once in a while, only on Faiba. But this is Faiba cable, not 4G for us.


So I should try this out? Have a couple of GBs to upload and Safaricom is best option after Faiba that I have right now.

1 Like

Actually, using a VPN works. @martingicheru thanks this will do for now but let me alert them.


Such an error on Faiba 4G? Sorry man.

1 Like

Yes man. But using it via VPN as suggested by @martingicheru and it’s working. Will have to deal with that for now though annoying.


Wordpress is now accessible via Faiba 4G. Think they might have fixed it or something.

1 Like

I tried yesterday and it worked so wondered a bit why it did not block me.

The issue was resolved. It was not working and they were aware of it. It now works flawless.