Safaricom Fibre To the Home Experiences,Please share

mpesa
safaricom

#683

The issue is not numbers but it seems like Safaricom is giving downloads priority and assigning all the bandwidth to any current download thus leaving the rest of the users without any bandwidth until the download is complete


#684

This is correct. I’m unable to browse anything on computer, TV, or phone when I have a PSN download going. I have the cheapest package, however.


#685

Well,I have been having same issues with FTTH in langata . Apparently when using netflix ,thr full package(1200 bob or sth) , it uses the internet at its maximum. So unless i change my FTTH package ,i cant use the internet if netflix is playing!!!


#686

I am on the 10mbps package and I don’t get these issues. However, my friend gas 5mbps and when downloading anything, you can’t browse at all.


#687

Funny how i thought i was the only one with this problem


#688

I’m guessing this all depends with your zone etc…i live in kasarani and we have both options of zuku and safaricom…i have used zuku since 2013 i think and it has been perfect…around june this year it was down thrice for about 30min each time…their customer care were responsive and issue solved…i have the 5mbps package but it pulls upto 6mbps and i am a heavy user i.e i use an android box for streaming every day, laptop and phones…little buffering when all devices are running at the same time…the safaricom one is perfect too and you should get it when you are fond of uploading videos…its upload speeds are high while that of zuku are close to zero…soo it all depends on your zone and how much you are willing to pay…my friend in south b had the zuku 10mbps and mine was waaaaay faster than his…he couldnt event properly stream a youtube video on 720p while i can stream on three devices at the same time.


#689

I found a small workaround,use psiphon vpn on the devices not doing the download.


#690

This works?


#691

Yes,i can confirm it works when used on devices not doing the download in your network as long as the VPN is connected.It allows for basic browsing/my pages load faster.


#692

How accurate are these speed measurements on Windows-the app store one? I’m getting 2Gb/s on ethernet. One thing I can say is that it’s crazy fast…


#693

2 Gb/s, where is that…!?


#694

I forgot to take a screenshot. I was downloading a game from the Windows store. It’s crazy, the max ethernet speed is 1000Mbps~1 Gbps but it was reading 2Gbps. I think it was an inaccurate reading…It was definitely fast…


#695

Were you by any chance using UoN (ADD) internet. That’s an area I know with one of the fastest speeds around


#696

Safaricom internet…


#697

Does Safaricom offer those speeds here in Kenya…!?
I thought they did max out at 40 Mb/s


#698

Have you tried to adjust settings on IDM and set a speed limit cap? If not try do so. IDM gobbles all the speeds when left untouched.


#699

The issue ain’t limited to IDM, even with direct downloads (browser downloads)


#700

It must have been an inaccurate measurement.


#701

I also encountered this issue. During the download, internet was not available on all other devices and even on other applications on the same computer.


#702

May be your case is different but I know many get confused with GB/s and gb/s