It's Time Techweez

tls
ssl
techweez

#21

That was fast! Thanks!

What beer do you take? I’ll buy two!


#22

There is something is still broken mate. http://techweez.com redirects to the wordpress login page and attempting to test your setup on SSL Labs throws an error.

Edit: For anyone who runs their own webserver, Mozilla have an awesome tool to help with configuration. Works with both apache and nginx.


#23

padlock on main site, yaaay! :grin:
sasa ukipumzika rudi forums :smile:


#24

Looking Good Techweez. Nice Work Team

image


#25

Next is taking those skills and quickly sorting out http://tamasha.tech

image


#26

Weh. Acha siasa. Forum first.


#27

Yes also noticed it since I visit most sites without typing www.


#28

Next I would propose you look at the redirects{301 - Moved Permanently} …
Force all :80 traffic to :443 …also regardless of www.SERVER_NAME .com OR SERVER_NAME.com should be upgraded to https://www.SERVER_NAME or just https;//SERVER_NAME.com


#29

I think there is a rewritecond on your .htaccess file …if you access www.techweez.com you can see a redirect on the headers …


#30

Also the site seems to set its own cookies …weird …

Screenshot%20from%202018-08-02%2016%3A38%3A25


#31

There’s a broken HTTP 302 redirect that points http://techweez.com to the WordPress login panel. It shows with the network monitor tool on my browser.


#32

At the time of writing this the redirect seems to be fixed …i.e the www.techweez.com what remains is the plain techweez.com
Seems like someone once setup a wordpress page then forgot about it …


#33

Sasa watu mmelia HTTPS iekwe mkafanya @martingicheru amechoma fuse mahali.


#34

:joy::joy: @deewinc eventually angeichoma tu, cuz ofcourse down the road angeweka tls. I suggest aendelee tu ndio in future he be fine when traffic increases.


#35

I believe this is fixed now.

Edit: Not, let me continue trouble-shooting what it is this plugin is doing that I can change.


#36

Ni plugin imekuleta kipindi? Ichomoe tu and ask for help on how to enable HTTPS by accessing the .htaccess file hidden in the root folder.


#37

@martingicheru if anything is wrong with the deployment of secure network, it’s okay to bring experts. imo


#38

In theory this should be a simple exercise but in practice even financial institutions get it wrong.


#39

Good news for privacy conscious consumers. TLS 1.3 has been officially accepted as a standard.

TL;DR it is more resistant to man in the middle attacks and provides performance improvements for both admins and developers.

The two modern browsers Firefox and Chrome (and theoretically all the Chrome clones) currently support the new standard.


#40

@martingicheru I think you might be losing potential customers due to this problem. I suggest you solve it once and for all, maybe get professionals and be done with ssl integration cuz I think ndio the cause. It has been like this for some days now, even after clearing cookies. Anyone else seeing this?
Capture